Re: Error loading xdp program that worked with bpf_load

Andrii Nakryiko

On Thu, Jun 11, 2020 at 1:41 PM Elerion <elerion1000@...> wrote:

I am using libbpf from here I'm not
using ebpf. I just linked to the ebpf issue because it seems like the
only thing related to this problem when I googled it.
Ok, that I can help with, then.

What's the kernel version? Where I can find repro? Steps, etc.
Basically, a bit more context would help, as I wasn't part of initial

On Thu, Jun 11, 2020 at 9:34 AM Andrii Nakryiko
<andrii.nakryiko@...> wrote:

On Thu, Jun 11, 2020 at 4:00 AM Jesper Dangaard Brouer
<brouer@...> wrote:

(Cross-posting to iovisor-dev)

Seeking input from BPF-llvm developers. How come Clang/LLVM 10+ is
generating incompatible BTF-info in ELF file, and downgrading to LLVM-9
fixes the issue ?

On Wed, 10 Jun 2020 14:50:27 -0700 Elerion <elerion1000@...> wrote:

Never mind, I fixed it by downgrading to Clang 9.

It appears to be an issue with Clang/LLVM 10+
This is newer Clang recording that function is global, not static.
libbpf is sanitizing BTF to remove this flag, if kernel doesn't
support this. But given this is re-implementation of libbpf, that's
probably not happening, right?

On Wed, Jun 10, 2020 at 2:38 PM Toke Høiland-Jørgensen <toke@...> wrote:

Elerion <elerion1000@...> writes:

[69] FUNC xdp_program type_id=68 vlen != 0
'vlen != 0' is the error. Not sure why you hit that; what's the output
of 'bpftool btf dump file yourprog.o' ?


Best regards,
Jesper Dangaard Brouer
MSc.CS, Principal Kernel Engineer at Red Hat

Join to automatically receive all group messages.