|
Re: using BPF for driver memory leak detection
<chaitanya.mgit@...> wrote:
+dev
<chaitanya.mgit@...> wrote:
+dev
|
By
Krishna Chaitanya
·
#1427
·
|
|
Re: [RFC PATCH v2 0/3] Implement bpf map queue
<mauricio.vasquez@...> wrote:
I did not check the detailed implementation for percpu freelist implementation,
but the general framework looks sound. I think the patch is ready to send
to netdev
<mauricio.vasquez@...> wrote:
I did not check the detailed implementation for percpu freelist implementation,
but the general framework looks sound. I think the patch is ready to send
to netdev
|
By
Yonghong Song
·
#1426
·
|
|
Re: [RFC PATCH v2 1/3] bpf: add bpf queue map
<mauricio.vasquez@...> wrote:
Maybe we should "&& (arg_type == ARG_PTR_TO_MAP_VALUE || type != SCALAR_VALUE)"?
<mauricio.vasquez@...> wrote:
Maybe we should "&& (arg_type == ARG_PTR_TO_MAP_VALUE || type != SCALAR_VALUE)"?
|
By
Yonghong Song
·
#1425
·
|
|
Re: [RFC PATCH 3/3] bpf: add sample for BPF_MAP_TYPE_QUEUE
<mauricio.vasquez@...> wrote:
There are still some values as it has bpf program doing "pop" operation.
<mauricio.vasquez@...> wrote:
There are still some values as it has bpf program doing "pop" operation.
|
By
Yonghong Song
·
#1424
·
|
|
[PATCH] BPF: helpers: New helper to obtain namespace data from current.
Hi All,
I have applied changes to add thenew helper: bpf_get_current_pidns_info using bpf-next branch.
Let me know if what you think.
From 932f55d885bf34443bb73ec4b24f9dd4b95b64c7 Mon Sep 17
Hi All,
I have applied changes to add thenew helper: bpf_get_current_pidns_info using bpf-next branch.
Let me know if what you think.
From 932f55d885bf34443bb73ec4b24f9dd4b95b64c7 Mon Sep 17
|
By
neirac
·
#1423
·
|
|
[RFC PATCH v2 3/3] bpf: add sample for BPF_MAP_TYPE_QUEUE
The example is made by two parts, a eBPF program that consumes elements
from a FIFO queue and prints them in the screen and a user space
application that inserts new elements into the queue each time
The example is made by two parts, a eBPF program that consumes elements
from a FIFO queue and prints them in the screen and a user space
application that inserts new elements into the queue each time
|
By
Mauricio Vasquez
·
#1422
·
|
|
[RFC PATCH v2 2/3] selftests/bpf: add test cases for BPF_MAP_TYPE_QUEUE
Signed-off-by: Mauricio Vasquez B <mauricio.vasquez@...>
---
tools/include/uapi/linux/bpf.h | 5 ++
tools/testing/selftests/bpf/test_maps.c | 71 +++++++++++++++++++++++++++++++
2
Signed-off-by: Mauricio Vasquez B <mauricio.vasquez@...>
---
tools/include/uapi/linux/bpf.h | 5 ++
tools/testing/selftests/bpf/test_maps.c | 71 +++++++++++++++++++++++++++++++
2
|
By
Mauricio Vasquez
·
#1421
·
|
|
[RFC PATCH v2 1/3] bpf: add bpf queue map
Bpf queue implements a LIFO/FIFO data containers for ebpf programs.
It allows to push an element to the queue by using the update operation
and to pop an element from the queue by using the lookup
Bpf queue implements a LIFO/FIFO data containers for ebpf programs.
It allows to push an element to the queue by using the update operation
and to pop an element from the queue by using the lookup
|
By
Mauricio Vasquez
·
#1420
·
|
|
[RFC PATCH v2 0/3] Implement bpf map queue
Bpf queue map is a new kind of map that provides a LIFO/FIFO queue
implementation.
In some applications, like a SNAT, it is necessary to keep track of
a pool of free elemenets, network ports in this
Bpf queue map is a new kind of map that provides a LIFO/FIFO queue
implementation.
In some applications, like a SNAT, it is necessary to keep track of
a pool of free elemenets, network ports in this
|
By
Mauricio Vasquez
·
#1419
·
|
|
Re: [RFC PATCH 3/3] bpf: add sample for BPF_MAP_TYPE_QUEUE
I am not sure, it is more an example than a test, real tests are already in tools/testing/selftests/bpf/test_maps.c.
Maybe we can rename it to queue_map_sample or something similar, or remove it if
I am not sure, it is more an example than a test, real tests are already in tools/testing/selftests/bpf/test_maps.c.
Maybe we can rename it to queue_map_sample or something similar, or remove it if
|
By
Mauricio Vasquez
·
#1418
·
|
|
Re: [RFC PATCH 1/3] bpf: add bpf queue map
I have no any preference over that, will do that way.
I missed that, will do.
I realized that I totally missed the support for preallocating elements.
In v2 I implemented a per cpu free list based
I have no any preference over that, will do that way.
I missed that, will do.
I realized that I totally missed the support for preallocating elements.
In v2 I implemented a per cpu free list based
|
By
Mauricio Vasquez
·
#1417
·
|
|
Re: Notification when an eBPF map is modified
I think that I need kprobe, map_update_elem and map_delete_elem are
defined in kernel space.
Thank You,
Raffaele
<sunny@...> ha scritto:
--
________________________________
Raffaele
I think that I need kprobe, map_update_elem and map_delete_elem are
defined in kernel space.
Thank You,
Raffaele
<sunny@...> ha scritto:
--
________________________________
Raffaele
|
By
Raffaele Sommese
·
#1416
·
|
|
Re: Notification when an eBPF map is modified
You likely want uprobes if your function is defined in userspace, not kprobes (which are for functions defined in kernel space).
relevant link:
You likely want uprobes if your function is defined in userspace, not kprobes (which are for functions defined in kernel space).
relevant link:
|
By
Sunny Klair
·
#1415
·
|
|
Re: Notification when an eBPF map is modified
Hello,
I have tried to use kprobe but it fails when I try to attach a kprobe
on that function with this error: raise Exception("Failed to attach
BPF to kprobe")
I use
Hello,
I have tried to use kprobe but it fails when I try to attach a kprobe
on that function with this error: raise Exception("Failed to attach
BPF to kprobe")
I use
|
By
Raffaele Sommese
·
#1414
·
|
|
BPF hackfest in Berlin, Sept 26th-27th (just before ASG! conf)
Hi,
We will have a BPF hackfest in Berlin on September 26th and 27th, 10am
to 5pm in the Kinvolk office. This is just before the All Systems Go!
conference (https://all-systems-go.io/), so there will
Hi,
We will have a BPF hackfest in Berlin on September 26th and 27th, 10am
to 5pm in the Kinvolk office. This is just before the All Systems Go!
conference (https://all-systems-go.io/), so there will
|
By
Alban Crequy
·
#1413
·
|
|
Re: Notification when an eBPF map is modified
bpf tracepoints have been removed from recent linux so the you need to
use kprobe to trace update/delete.
typical map_update_elem and map_delete_elem first argument is
'struct bpf_map *map', you can
bpf tracepoints have been removed from recent linux so the you need to
use kprobe to trace update/delete.
typical map_update_elem and map_delete_elem first argument is
'struct bpf_map *map', you can
|
By
Yonghong Song
·
#1412
·
|
|
Re: Notification when an eBPF map is modified
Hello everybody,
I was looking for a similar mechanism,
I need to trace an event on map update/delete, I have tried with
tracepoint but I can recover only the file descriptor of map and I
need the map
Hello everybody,
I was looking for a similar mechanism,
I need to trace an event on map update/delete, I have tried with
tracepoint but I can recover only the file descriptor of map and I
need the map
|
By
Raffaele Sommese
·
#1411
·
|
|
Re: [RFC PATCH 3/3] bpf: add sample for BPF_MAP_TYPE_QUEUE
<mauricio.vasquez@...> wrote:
Could you put the test in tools/testing/selftests/bpf? This way, it
will be executed by various
kernel testing infrastructure.
For /sys/fs/bpf mount, you can check
<mauricio.vasquez@...> wrote:
Could you put the test in tools/testing/selftests/bpf? This way, it
will be executed by various
kernel testing infrastructure.
For /sys/fs/bpf mount, you can check
|
By
Yonghong Song
·
#1410
·
|
|
Re: [RFC PATCH 2/3] tests/bpf: add some test cases for BPF_MAP_TYPE_QUEUE
<mauricio.vasquez@...> wrote:
Order the declaration based on reverse Christmas tree shape.
<mauricio.vasquez@...> wrote:
Order the declaration based on reverse Christmas tree shape.
|
By
Yonghong Song
·
#1409
·
|
|
Re: [RFC PATCH 1/3] bpf: add bpf queue map
<mauricio.vasquez@...> wrote:
It is totally up to you, but you could replace the above licensing portion from
"This program" to 'more details" with
/* SPDX-License-Identifier: GPL-2.0
<mauricio.vasquez@...> wrote:
It is totally up to you, but you could replace the above licensing portion from
"This program" to 'more details" with
/* SPDX-License-Identifier: GPL-2.0
|
By
Yonghong Song
·
#1408
·
|