Topics

Recommended LLVM version for bcc 0.7.0

Tom Stellard
 

Hi,

Is there a particular version of LLVM that is recommended to use with
bcc 0.7.0?

Thanks,
Tom

Yonghong Song
 

On Wed, Nov 28, 2018 at 7:00 AM Tom Stellard <tstellar@...> wrote:

Hi,

Is there a particular version of LLVM that is recommended to use with
bcc 0.7.0?
All LLVM versions ( >= 3.7.1) should work for x86, but to use some features
like BPF debug=8 to dump the source embedded byte code, you need
llvm 6.0 or later.


Thanks,
Tom